VisioList 0.5

Mark

Administrator
Staff member
This is a maintenance release addressing all known/reported issues from 0.4 as well as some security fixes.

Some of the new features:

Ad / Content rotator plugin
Edit skin templates from admin panel
multi-user premium purchase and banner uploads

Please read the following carefully to ensure a smooth install/upgrade experience

Fresh installs - Download install-0.5.zip and follow install instructions in the user manual.

BEFORE UPGRADING ENSURE YOU HAVE A COMPLETE BACKUP

Upgrades from 0.4 or 0.3 - Download upgrade-0.5.zip and overwrite all files, then go to your admin panel, click "plugins", then click the install icon beside "Ads".

Upgrades from 0.2 -
1) Download upgrade-0.5.zip and overwrite all files
2) then run the update script at: youtsite.com/install/update0-3.php
3) Go to your admin panel, click "plugins", then click the install icon beside "Ads".

If you are using a version from before 0.2 then you need to update to 0.2 before upgrading to 0.5

If you have any problems let us know and we'll get right to work on them.

enjoy!
 

Attachments

Mark

Administrator
Staff member
for fresh installs you may encounter an error when saving settings from admin. This is because I included the SEO plugin with this release.

to correct, simply go to admin -> plugins -> and click the "install" icon beside SEO


and you should be all set!
 

Anna

Member
Found a bug in the screenshot part. When the new screenshot is renderd the filename has an "-" before _small.jpg _med.jpg and .png so the screenshots are not showing up on the webpage.
 

Basti

Administrator
Staff member
Indeed, this seems to happen once you request a screen where the url contains "/". We will investigate and post a fix later.
 

Anna

Member
Apprently the bug with opportunity for people to click on multiple user sites when in their conrol panel stil exists ;.(See attached pic). I can not do it, but one of my newer members can. Something that need adressing ASAP!

 

Basti

Administrator
Staff member
No, this issue is not present anymore, but you most likely havent applied the steps to fix it

make sure you have join.php code like the one in the following topic. If you have upgraded to 0.5 new members are fine, but i guess you havent created patch.php when you have read about this issue right?
If you havent made that, existing members from 0.4 havent the owner table filled
http://visiolist.com/community/threads/suggestions.176/
 

Mark

Administrator
Staff member
Correct, this was an issue with new members who joined on 0.4

best fix is as follows:

create a new file in your VisiList root called "patch.php" and paste the contents below

PHP:
<?php

define('ATSPHP', 1);
$CONF = array();
$FORM = array();
$TMPL = array();

include('settings_sql.php');

            require_once("sources/sql/mysql.php");
            $DB = "sql_mysql";
            $DB = new $DB;

          if ($DB->connect($CONF['sql_host'], $CONF['sql_username'], $CONF['sql_password'], $CONF['sql_database'])) {

$result = $DB->query("SELECT username FROM {$CONF['sql_prefix']}_sites WHERE owner = ''", __FILE__, __LINE__);
    while (list($newowner) = $DB->fetch_array($result)) {

    $DB->query("UPDATE {$CONF['sql_prefix']}_sites SET owner = '{$newowner}' WHERE  username = '{$newowner}'", __FILE__, __LINE__);

    echo "Added Ownership to $newowner<br />";

    }

    }
then point your browser to yoursite.com/patch.php

you will see the sites with ownership corrections listed

Delete this file when your done.
 

Anna

Member
We have updated for 0.5, but since it is my fiance doing it and not me I do not know if there were some issues updating. The member who brought this to my attention did indeed sign up in 0.4. So the scenario you tell is very plausible. Will test the patch and let you know!
 

Mark

Administrator
Staff member
thanks, this was a confirmed bug in 0.4 release, not the fault of your update :)
 

Karl

Member
License Active
The patch worked thank you.

My only concern is that if my users are like me they may or may not figure out that they have to click on the url for it to take them to the link codes. My first thought when I went to link code area is okay there is my url but where are the link codes. I understand why this was done after thinking about it, would it not be bettter to put a note or something to indcate that the url needs to be clicked on to get the link code.
 

Basti

Administrator
Staff member
Did your members for sure asked that?? oh wow lol...A note can be added easily but wow this suprise they cant figure out that they have to click one of their urls
 

Karl

Member
License Active
Unfortunately not all members that submit sites are not as web savvy as we would like them to be, so things need to be laid out in layman’s terms. A lot of my members would be people that have had their sites built for them and they are trying to promote the sites themselves so it would all be new and bewildering to them as they would not have had much experience with these things. It may be easier for the people that have niche sites aimed at users that are more computer and internet savvy.
 

Mark

Administrator
Staff member
Indeed, Easy enough to add a few more definitions to the language file, this will be included in 0.6 :)
 

Djack

Member
Hi Mark,
I've tried to upgrade my visiolist 0.2 to 0.5, and there are many errors:

Code:
Warning: include(plugins/Premium/languages/english.php) [function.include]: failed to open stream: No such file or directory in /public_html/index.php on line 135
 
Warning: include(plugins/Premium/languages/english.php) [function.include]: failed to open stream: No such file or directory in /public_html/index.php on line 135
 
Warning: include() [function.include]: Failed opening 'plugins/Premium/languages/english.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /public_html/index.php on line 135
 
Warning: include(plugins/core/languages/english.php) [function.include]: failed to open stream: No such file or directory in /public_html/index.php on line 135
 
Warning: include(plugins/core/languages/english.php) [function.include]: failed to open stream: No such file or directory in /public_html/index.php on line 135
 
Warning: include() [function.include]: Failed opening 'plugins/core/languages/english.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /public_html/index.php on line 135
 
Warning: include(plugins/.DS_Store/languages/english.php) [function.include]: failed to open stream: Not a directory in /public_html/index.php on line 135
 
Warning: include(plugins/.DS_Store/languages/english.php) [function.include]: failed to open stream: Not a directory in /public_html/index.php on line 135
 
Warning: include() [function.include]: Failed opening 'plugins/.DS_Store/languages/english.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /public_html/index.php on line 135
 
Warning: include(plugins/ElegantJoin/languages/english.php) [function.include]: failed to open stream: No such file or directory in /public_html/index.php on line 135
 
Warning: include(plugins/ElegantJoin/languages/english.php) [function.include]: failed to open stream: No such file or directory in /public_html/index.php on line 135
 
Warning: include() [function.include]: Failed opening 'plugins/ElegantJoin/languages/english.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /public_html/index.php on line 135
 
Fatal error: Database error in "/public_html/index.php(297) : eval()'d code" on line 8
 
Table 'topgame2.next_osbanners' doesn't exist in /public_html/sources/sql/mysql.php on line 88
Can you please help me beacause all my members can't access to my toplist...
Thanks,
Djack
 

Mark

Administrator
Staff member
Those errors are a result of files not being uploaded, and the instructions in RED in the first post not being followed.

1) upload ALL files
2) follow the instructions EXACTLY as they are outlined above.
 

Djack

Member
For the last line, it's ok... the table wasn't the good one.(don't knwo if it's clear)
But this line is now replace by :

Code:
Unknown column 'cat_description' in 'field list' in /public_html/sources/sql/mysql.php on line 88
 

Mark

Administrator
Staff member
that error means you need to run the installer for the "SEO" plugin and you should be ok. Admin -> plugins
 
Top