It's Just Not Happening

Michel

New Member
License Active
Time to upgrade to 1.6 I thought and clicked through to PayPal to get the necessary download links.

Alas, no matter how hard I try (upgrading in steps, or a fresh install) while reading through what went wrong for everyone else, it's just not happening; so bleary-eyed, I rolled everything back.
 

Mark

Administrator
Staff member
Sorry you are having troubles but without any error messages or details of what went wrong, it's very difficult for me to offer much advice.
 

Michel

New Member
License Active
Hi Mark,

That's the problem. No errors, just a blank page in the admin when I try to edit a member.

It all started going wrong when our host upgraded PHP to 7.2 by default. I rolled that back to 5.6 to at least get the front end of Topsites to appear again, as nothing was working.

Now I can't edit members.

Well, I can - but the changes don't save. I can make manual changes in the database though.
 

Mark

Administrator
Staff member
Hi Michel, your hosting account should have an error_log which will show you the errors happening. Those really old versions of VisioList won't work with PHP 7.2 so you will need to run the updater on 5.6 then update to 7.2 once VL is updated, you may also disable all plugins first to avoid any of those interfering.

We do offer upgrade service for $20 if you decide that's an easier route for you. The installer is pretty straight forward, but I believe there were some major changes along the way that could complicate things, especially with regards to plugins.
 

Michel

New Member
License Active
I can't disable plugins in Admin. Would putting a 0 in the database table disable them?
 

Mark

Administrator
Staff member
I can't disable plugins in Admin. Would putting a 0 in the database table disable them?
yes you can change the folder name on each plugin like: 0_

so for example:
VoteMessage
becomes
0_VoteMessage
 

Michel

New Member
License Active
Sounds good.

I'll save it for the weekend when I can concentrate a little better; and have a little more time to put things right.

I guess it might be a good idea to change the skin back to default, as well.
 

Mark

Administrator
Staff member
indeed, going from 0.6 to the current version has a lot of changes and new templates, you will most certainly want to use the default skin included with the current release and apply your customizations via the child skin folder.
 

cyan12

New Member
License Active
try to check if the Premium Start Date (YYYY-MM-DD) on the specific member is blank, if yes then put 0000-00-00 and try again this should be work,
but Mark maybe you can take a look why it happen because i had the same issue when the premium start date is empty
 

Basti

Administrator
Staff member
That was an old behavour and should not happen anymore since 1.6, not sure exactly.
Did it happen with a newer version? cause normally the changed behavour is set the column to NULL if empty
 
Top