Voting Issues...

Discussion in 'General Help' started by aikidesi, Jan 1, 2019.

  1. aikidesi
    • Licensed

    aikidesi Member

    For the past several days, a couple of members have been complaining to me that votes are not registering... I had tried it a few times and it seemed to be ok but, after getting another complaint, I tried again today and experienced the issue.
    I see some members with votes so it must be occurring inconsistently.
    Any one else experiencing this?
    Frank
    TopBandsAndMusicians.com
  2. aikidesi
    • Licensed

    aikidesi Member

    Still getting complaints and still seeing it happening... Mark/Seb - Any idea of what could be going on?
    Thank you!
  3. Basti
    • Staff

    Basti Administrator Staff Member

    In order to track/test this, we need some minimal info at least

    1) a few sample usernames where it happens
    2) Any plugins installed which temper with gateway / voting?
    3) I see a redirect to subfolder /topbands/ , are the members with issue linking to this subfolder? If not, the issue might be redirect related
  4. aikidesi
    • Licensed

    aikidesi Member

    Hey Seb - It seems to be happening on all users, at least all the random ones I've tried. The guy complaining the most is Tom Riccardi (http://www.topbandsandmusicians.com/topbands/details/Tom/).
    I haven't done anything to the site in well over a year so no new plugins and that redirect was set up well over a year ago; everything has been working fine until just recently.
    I do see votes getting recorded but perhaps something is delaying them now... Is that possible?
    If you vote for someone, sometimes you can see it reflected immediately but, more often than not now, it doesn't show up.
  5. Basti
    • Staff

    Basti Administrator Staff Member

    the sid parameter on your gateway vote link is cached, which should not happen. At least not so long

    This line in .htaccess, you have something similar. This is from vl 1.5 default commented
    Code:
    <FilesMatch ".(html|htm|php)$">
    #Header set Cache-Control "max-age=60, private, proxy-revalidate"
    </FilesMatch>
    Is it commented or not? ( comment starts with # at the Header part )
    If it is not commented, pls put the # sign back on there and let me know once done so I can test again

    If it is indeed not commented, it means 1 min cache. But the issue is really bad on chrome, and it doesn't seem to respect that 1 min anymore and keeps things cached.
    Google cache is a real ****** lately

    EDIT:: I see on your gateway a max-age cache of 600, that means 10 min html cache. Remove that

    Ill probably remove that default htaccess tuning in 1.6 , its not good. You should not cache something which needs a different value on each load
    Last edited: Jan 4, 2019
    Mark likes this.
  6. Mark
    • Staff

    Mark Administrator Staff Member

    Awesome catch man! I spent an hour on this today spinning my wheels :)
  7. aikidesi
    • Licensed

    aikidesi Member

    You da man, Seb! But where do I change that? The only .htaccess file I can find is under the public_html directory and looks to be a remnant from when this was a Wordpress site... spent a ton of time on that site and it was hacked & destroy! It looks nothing like what you have above...

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
  8. aikidesi
    • Licensed

    aikidesi Member

    P.S. Any idea why this would suddenly become an issue within the last week? Think I was hacked again?
  9. Basti
    • Staff

    Basti Administrator Staff Member

    I honestly doubt it just started recently, must be pure luck people not noticed or browser caching have been become something else, doubt that though

    Nothing in /topbands/ ? there must be, else your clean urls like /details/username/ would not work.
  10. aikidesi
    • Licensed

    aikidesi Member

    Ok, sorry Seb, missed it before... I found it but, in all the lines that have "header", there is a #... So they are all commented out already, right? Here's that section...

    ################################
    ## PERFORMANCE TUNING
    ## OFF BY DEFAULT

    <FilesMatch ".(ico|pdf|flv)$">
    #Header set Cache-Control "max-age=29030400, public"
    </FilesMatch>

    # 1 WEEK
    <FilesMatch ".(jpg|jpeg|png|gif|swf)$">
    #Header set Cache-Control "max-age=604800, public"
    </FilesMatch>

    # 2 DAYS
    <FilesMatch ".(xml|txt|css|js)$">
    #Header set Cache-Control "max-age=172800, proxy-revalidate"
    </FilesMatch>

    # 1 MIN
    <FilesMatch ".(html|htm|php)$">
    #Header set Cache-Control "max-age=60, private, proxy-revalidate"
    </FilesMatch>

    <filesMatch "\.(js|css)$">
    #Header set Content-Encoding x-deflate
    # Header set Content-Encoding compress
    # Header set Content-Encoding x-gzip
    </filesMatch>
  11. Basti
    • Staff

    Basti Administrator Staff Member

    Then your server might set a default cache, pls try setting max-age=0 and uncomment in the following
    Code:
    <FilesMatch ".(html|htm|php)$">
    #Header set Cache-Control "max-age=60, private, proxy-revalidate"
    </FilesMatch>
  12. aikidesi
    • Licensed

    aikidesi Member

    Oh oh... somehow corrupted that file and now the site won't load at all.
  13. aikidesi
    • Licensed

    aikidesi Member

    Ok... got it restored... Phew!
  14. aikidesi
    • Licensed

    aikidesi Member

    Seb - I'm using Notepad to edit .htaccess but, every time, the site no longer loads. Is there a preferred method to edit/modify that file?
  15. Basti
    • Staff

    Basti Administrator Staff Member

    Notepad probably kills line breaks or something, I dunno. Notepad isn't good for anything other than text files usually, use a real editor. For now you could use cpanel file manager also I guess
  16. aikidesi
    • Licensed

    aikidesi Member

    That did the trick and the voting appears to be registering correctly now... Thank you, Seb!
  17. Basti
    • Staff

    Basti Administrator Staff Member

    Nice, glad its resolved
    will try to work out something for vl 1.6 or 1.7 which fixes this without modifies to htaccess
  18. aikidesi
    • Licensed

    aikidesi Member

    As always, appreciate the assist!

Share This Page