Problem instalation

Discussion in 'Installation And Upgrade Help' started by haritz, Aug 1, 2015.

  1. haritz

    haritz New Member

    Hello,

    When I try to import english nothing happen: http://prntscr.com/7zmdbs

    I think that the problem is on my hosting because I installed in a public hosting and it worked.

    Could be the reason of this problem not having "FreeType" installed?

    Thanks!
  2. Basti
    • Staff

    Basti Administrator Staff Member

    Hey for the start, look into your language folder.

    1) is no english.php in there?
    - Then go into languages/import/ and copy english.php into /languages/
    Since you have VL installed except the language, this will make steps easier.

    2) Alright, next up please open /languages/importer.php
    Code:
    // Set encoding for multi-byte string functions
    
    Above that line, paste the following and save the file
    Code:
    error_reporting(E_ALL);
    3) Now pls download any language pack from here http://visiolist.com/community/forums/language_packs/
    Unzip it, and place file into /languages/import/

    4) Now we import this file to test the error reporting.
    Log into admin panel and move you mouse over the top menu item "Content" and click "Manage languages"
    - On the right side there you see 3 links, click on "Import" and select the pack you just downloaded

    Hopefully the page which opens ( same as on install ) will show us what exactly is missing, my guess here some ob_ functions disabled or fwrite.
    We will see
    Mark likes this.
  3. haritz

    haritz New Member

    I try to do it but I can not or I am doing it wrong.

    This coul be the problem: Warning: mysql_connect(): Headers and client library minor version mismatch. Headers:50542 Library:50623 in /home/gjtopcom/public_html/admin/sources/sql/mysql.php on line 32

    When I try to click in "Manage languages" or any other site I need to use admin password again but it does not work because I go automatically to "Main Page".
  4. Basti
    • Staff

    Basti Administrator Staff Member

    Yes script is not correctly logging you in because of that error output on the page, which we would need to fix to test the language import.
    Contact your host. Looks like mysql was updated to mysql 5.6 incorrectly

    So if they just upgrade mysql ( no fresh install ), mysql uses the old library which cause this error

    Host should normally know what to do, but i think this commands would solve it.
    Code:
    apt-get remove php5-mysql
    Code:
    apt-get install php5-mysqlnd
    Last edited: Aug 1, 2015
    Mark likes this.
  5. haritz

    haritz New Member

    Basti thank you! I changed my PHP version and now works.

    Thank you bro!
    Mark and Basti like this.

Share This Page