New Install 1.4 issues

Discussion in 'Installation And Upgrade Help' started by Mike.Dallas, Jul 14, 2015.

  1. Mike.Dallas

    Mike.Dallas Member

    Hello, I have some issues to install the 1.4 release.

    1. With the .htaccess located in the root folder I have a "500
    Internal Server Error.

    2. After deleting the .htaccess file, the install stuck by "install/index.php?import=1"

    Host: PHP 5.3.3, MySQL 5.1.73

    Trying on other Host:

    Warning: require_once(./sources/sql/.php) [function.require-once]: failed to open stream: No such file or directory in /kunden/115651_34369/serverworks/ranking/index.php on line 56

    Fatal error: require_once() [function.require]: Failed opening required './sources/sql/.php' (include_path='.:/usr/local/lib/php') in /kunden/115651_34369/serverworks/ranking/index.php on line 56

    Ignored, go to install:
    MySQL 5.6.19

    System Requirements
    [​IMG] Curl functions are available.
    [​IMG] GD functions are available.
    [​IMG] iconv functions are available.
    [​IMG] MB_String functions are available.
    [​IMG] FreeType Installed
    [​IMG] PHP Version: 5.2.17
    [​IMG] CGI PHP Installed - NO problems expected
    [​IMG] settings_sql.php is writeable
    [​IMG] button_config.php is writeable
    [​IMG] The banners directory is writeable
    [​IMG] The languages directory is writeable
    [​IMG] The plugins directory is writeable
    [​IMG] The screens directory is writeable

    Fatal error: Database error in "/kunden/115651_34369/serverworks/ranking/install/index.php" on line 879

    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '`new_day_boost` INT(11) NOT NULL, `new_week_boost` INT(11) N' at line 53 in /kunden/115651_34369/serverworks/ranking/sources/sql/mysql.php on line 89
    Last edited: Jul 14, 2015
  2. Basti
    • Staff

    Basti Administrator Staff Member

    Regarding the htaccess, the following on line 1 in .htaccess
    Code:
    Options +FollowSymLinks -Indexes
    If you use Options directive in htaccess with parameter which has been forbidden in main Apache config, server will return HTTP 500 error code.
    So, most likely "FollowSymLinks" is diabled and not allowed to be turned on, some hostings unfortunatly have this, like 1&1 if im not wrong

    Try to use "SymLinksIfOwnerMatch" instead please and let me know.
    If that works ill have to discuss with Mark how we best handle this

    Regarding the database error
    If its a fresh install, no wonder. Nothings installed yet :)


    That error line not really goes hand in hand with the error description
    Looking at the fresh install, line 879 is not what is described there.

    Could you post here or pm me your install/index.php please?
    Last edited: Jul 15, 2015
  3. Mike.Dallas

    Mike.Dallas Member

    Basti, it was really a fresh install, but that should be a issue?
    Sorry for the joke but that sounds like by installing VisioList ; "Ups, VisioList can not be installed, database appears to be missing"

    I solved the issue installing:
    V.1.4 = fails

    VL.0.9 = working like a charm, database will be installed
    VL. 1.0 = working like a charm, database will be installed
    VL. 1.3 = working like a charm, database will be installed
    VL.1.4 update = working like a charm, database will be not updated

    [​IMG]

    Because the VL.1.4 update fails with blank page, I sent you the data you need to try to instell a clean 1.4

    Thanks
  4. Basti
    • Staff

    Basti Administrator Staff Member

    That was related to this error with that fresh install thing, that error shows me you accessed the main index, not the install. Hence the question / statement from me.

    Looking at the data youve sent, cheers.
  5. Basti
    • Staff

    Basti Administrator Staff Member

    This was indeed the issue with your hosting and using SymLinksIfOwnerMatch works.

    And there was a little missing comma in the installer, which caused that blank page afterwards. Thanks for your help :)
  6. Mike.Dallas

    Mike.Dallas Member

    Thank you for fixing this issue, I hope that VL 1.4.zip will be fixed, because the missing comma in the installer.

    Oh, I see it was already fixed, thanks again.

Share This Page