Forbidden Error when trying to install language

Discussion in 'Installation And Upgrade Help' started by Andy, Apr 1, 2015.

  1. Andy

    Andy Member

    Hiya,

    Im working on a linux web server with php version 5.3.24. Looking at info in joomla it says that its running FPM/FastCGI.

    I thought I would try and have a boost traffic period for my biz so planned on starting a few new toplists. I have a problem though. I have uploaded the visio list script in a sub directory on one of my domains but when i get to the point when it says to install the english language Im getting a forbidden error saying i don't have permission to access the file.

    Ive tried changing permissions on the file and the ownership seems to be the same as the domain. Im not sure where I'm going wrong? I have other domains on the server running visio list so it shouldn't be a problem even though its a fairly new server.

    I did get one red light on the system requirements saying that CGI PHP was not installed but i read in somebody else post that this shouldn't prevent the script installing.

    Not sure where I'm going wrong. Any thoughts at all?

    Andy
  2. Basti
    • Staff

    Basti Administrator Staff Member

    If you get that, then no, you do not run fastCGI on your toplist. Most likely you have a custom php.ini in your joomla enabling you to do that there.

    If you have that red light, either make your host enable fastcgi globally ( really should do that, eases just about everything ) or chmodd 777 the language folder, so php can write into that directory. changing permission of the import/english.php doesnt help in this matter.
  3. Mark
    • Staff

    Mark Administrator Staff Member

    You might also try this (but using suPHP or FastCGI is a better option as you will also have problems editing skins, uploading plugins etc):

    /languages/ - chmod 777
    /languages/english.php - chmod 666
  4. Andy

    Andy Member

    Thanks. Server support are telling us that fast cgi is already enabled on the server. I have to send them something they can test on their end so guess I will do that for now. Thanks guys :)
  5. Andy

    Andy Member

    Hiya,

    Server support bods wrote back and said:

    Your server is running the PHP FastCGI Process Manager, which is a daemonized version of PHP FastCGI. The script may be looking for the apache module, which is why it is failing. With this is mind...​

    As per their and your suggestion I've chmod the languages folder to 777 and english.php to 666 but that isn't working either I'm afraid. Now I am just getting a blank page when i move from the check the settings part of the installation to the part where it used to require me to import the script

    Do we need the apache module like they mention? Any thoughts?

    I know its easter btw so whenever you have time is fine :)

    Andy
  6. Mark
    • Staff

    Mark Administrator Staff Member

    blank page means a suppressed fatal error, please try to empty your database and re-run the installer. You can also check your error_log on your server to see what the error was.

Share This Page