Created [Req] Minecraft Votifier Plugin

Basti

Administrator
Staff member
The plugins sends text over the votifier, if you take a look inside the plugin file classes_record_in.php
You will find a block like this, which is whats gets sent over
Code:
            // Details of the vote.
            //1st portion is the word VOTE
            //2nd is the website referring (your topsite)
            //3rd is the minecraft username
            //4th is the IP Address they're coming from.
            //5th is the current time of the vote being cast.
            $str = "VOTE\n" .
                   "{$CONF['list_name']}\n" .
                   "{$minecraft_user}\n" .
                   "{$ip}\n" .
                   time()."\n";
Im not actually sure it could be anything you want, but it probably can, ( \n makes a new line )
 

legendz

AcemanWolf
License Active
Make a new line?

$str = "VOTE\n" .
"{$CONF['list_name']}\n" .
"{$minecraft_user}\n" .
"{$ip}\n" .
time()."\n";
"\n"

like that?
 

Basti

Administrator
Staff member
No, you have to apply to $str

you see there after time() is semicolon, that marks the end of a string, so you cant simply put \n after it, it has to go onto $str
Code:
$str = "VOTE\n" .
"{$CONF['list_name']}\n" .
"{$minecraft_user}\n" .
"{$ip}\n" .
"some other text, hey ho\n" . 
time()."\n\n";
you see like this, i inserted another line with text before the time part, and time part gets 2 line breaks ( not useful really, just for learning purpose
 

legendz

AcemanWolf
License Active
No, you have to apply to $str

you see there after time() is semicolon, that marks the end of a string, so you cant simply put \n after it, it has to go onto $str
Code:
$str = "VOTE\n" .
"{$CONF['list_name']}\n" .
"{$minecraft_user}\n" .
"{$ip}\n" .
"some other text, hey ho\n" .
time()."\n\n";
you see like this, i inserted another line with text before the time part, and time part gets 2 line breaks ( not useful really, just for learning purpose
I dont understand. It is still not sending to the server.
 

Basti

Administrator
Staff member
What you mean it is not sending to the server? you asked how to modify what is sent to server lol.
Keeping further discussion in PM, looks like wrong html on your end is causing this
 
Last edited:
Top