OUTDATED PLUGINS

Discussion in 'General Help' started by softdevsalon, Feb 1, 2019.

  1. softdevsalon
    • Licensed

    softdevsalon New Member

    Hi, I just want to ask for help, I tried using some of the plugins like facebook, spamforum. But It didn't work. Tried some troubleshooting still not working. Now can't save settings and all got 500 page error. Removing all plugins installed solved the plugin.

    When do you plan releasing new version of plugins?
    When do you plan releasing new version of visiolist?

    Thanks.

    What shall I do now? Stick to the simple one?
  2. Basti
    • Staff

    Basti Administrator Staff Member

    That sounds like you did not installed those plugins, but just uploaded them to ftp. That's correct?

    some plugins modify the database, like facebook, its suggested you upload the downloaded zip via admin -> plugins. When doing that it automatic performs the updates and put the files on your ftp.
    If you can't do it that way due server limitations and do a manual upload, you need need to visit admin -> plugins afterwards and click the install icon for the plugins in question ( if no icon = no database changes )
  3. softdevsalon
    • Licensed

    softdevsalon New Member

    I can't install using via admin. i still got an error 500. Even changing version of php 5.5,5.6 and 7.0..
    Uploading via ftp still can't install when clicking install icon..error 500. I dont know what to do and how to use some plugins.. Can't wait you release the new version..i hope it will solve.
  4. Basti
    • Staff

    Basti Administrator Staff Member

    Ah ok I found the issue, the plugin install file was not updated when we switched from MySQL to mysqli, it uses hardcoded MySQL function instead our db wrapper function

    please open plugins/facebook/install.php

    Code:
    mysql_num_rows
    replace the word above ( found 2 times ) with the following
    Code:
    $DB->num_rows
    That should fix the issue with facebook plugin. If you have issues with install on other plugins, most likely the same issue
    Ill update and check all plugins again and post updates along with VL 1.6
    Last edited: Feb 4, 2019
  5. softdevsalon
    • Licensed

    softdevsalon New Member

    It didn't work when installing via admin. I need to install it via FTP. It works.
    Problem is the plugin facebook is not allowing permission. It might be the facebook since they upgraded their dev UI or the code in plugins.
  6. Basti
    • Staff

    Basti Administrator Staff Member

    Yea, that might be. Those permissions are quite old to say it nicely :) Looking at their docs, things changed 200%
  7. softdevsalon
    • Licensed

    softdevsalon New Member

    You have any solutions to this.?
    Or just wait for 1.6?
  8. Basti
    • Staff

    Basti Administrator Staff Member

    Ill have to rewrite the plugin, 1.6 not fixes that. Its the FB api which changed. So need to test myself. Will give you an update next few days
  9. softdevsalon
    • Licensed

    softdevsalon New Member

    Thank you. I will be waiting.
    Any update?

  10. Basti
    • Staff

    Basti Administrator Staff Member

    Went through all but facebook and twitter plugin and updated those who needed. After this VL 1.6 will follow
  11. softdevsalon
    • Licensed

    softdevsalon New Member

    What do you mean? I need facebook plugin.
  12. Basti
    • Staff

    Basti Administrator Staff Member

    Yes, and I told you I updated all but that and twitter. I did not say I not update them
  13. softdevsalon
    • Licensed

    softdevsalon New Member

    So can we use the Facebook plug in now?
  14. Basti
    • Staff

    Basti Administrator Staff Member

    Can you show a bit patience please? I'm in the middle of updating this
  15. Basti
    • Staff

    Basti Administrator Staff Member

    Alright, please test out facebook now if you wish. Please take note of the updated install instructions.
    I have tested this out quite a bit, but if anything wrong, please let me know
  16. softdevsalon
    • Licensed

    softdevsalon New Member

    I cant test this , my site is not yet a ssl / https .
  17. Basti
    • Staff

    Basti Administrator Staff Member

    Ah I see, alright.

Share This Page